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The IDL Intelligent Tools (iTools) 
 

The IDL Intelligent Tools (iTools) are a set of interactive utilities that combine data 

analysis and visualization with the ability to produce presentation quality graphics.  

The iTools allow users to continue to benefit from the control of a programming 

language, while enjoying the convenience of a point-and-click environment.  There 

are 7 primary iTool utilities built into the IDL software package.  Each of these seven 

tools is designed around a specific data or visualization type : 

 

• Two and three dimensional plots (line, scatter, polar, and histogram style) 

• Surface representations 

• Contours 

• Image displays 

• Mapping 

• Two dimensional vector flow fields 

• Volume visualizations 

 

The iTools system is built upon an object-oriented component framework 

architecture that is actually comprised of only a single tool, which adapts to handle 

the data that the user passes to it.  The pre-built iPlot, iSurface, iContour, iMap, 

iImage, iVector and iVolume procedures are simply shortcut configurations that 

facilitate ad hoc data analysis and visualization.  Each pre-built tool encapsulates the 

functionality (data operations, display manipulations, visualization types, etc.) 

required to handle its specific data type.  However, users are not constrained to work 

with a single data or visualization type within any given tool.  Instead, using the 

iTools system a user can combine multiple dataset visualization types into a single 

tool creating a hybrid that can provide complex, composite visualizations. 

 

 

 

Image Display, Enhancement, and Regions of Interest 
 

The IDL iImage tool can be used to display gridded 2-Dimensional arrays of data in 

image form.  The iImage utility has built-in support for the input of images in BMP, 

DICOM, GIF, JPEG, JPEG2000, PICT, PNG, and TIFF formats.  Once an image is 

loaded into the iImage tool there are several options for visualizing, manipulating, 

and processing the imagery.  Furthermore, the library of IDL routines contains a rich 

suite of image processing algorithms. 

 

In the following exercise, the image data from the example data file “MRI.dcm” will 

be input into the iImage utility.  This example data file is located in the “data” 

subfolder. 

 

The file “MRI.dcm” is in DICOM format, which is the industry standard for storing 

imagery and diagnostic patient information in the radiology community.  This file 

contains a grayscale (black-and-white) image of a MRI exam involving a single slice 

through a human brain.  The MRI image can be loaded into the iImage utility using 

the following steps : 
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1. At the IDL> command prompt execute the statement "iImage". 

2. Click on the open file  button on the toolbar of the IDL iImage window. 

3. Select the “MRI.dcm” file and hit “Open”.  An image graphical object will be 

automatically inserted into the utility. 

 

Along the right-hand side of the iImage utility is a panel that is not present on the 

other iTools utilities.  This panel contains cursor query, histogram manipulation, and 

ROIs (Regions Of Interest) tools specific to the image graphical object. 

 

4. While the image object is selected and the iTool is in Select/Translate arrow 

mode, move the mouse cursor over the image and watch the “Pixel Location:” 

and “Pixel Value:” fields update. 

 

The origin location for the image (0,0) is considered to be the pixel in the lower-left 

hand corner.  Within the “Pixel Value:” field there is actually 2 numbers displayed: 

the first being the actual image data pixel value, and the second within parentheses 

is the scaled display value [Fig. 1].  Since the computer monitor can only display 256 

(or sometimes less) levels of discrete brightness for each color channel, all image 
data is scaled to fit within the range of 0 � 255 automatically by the iImage utility if 

it does not already.  The “Min:” and “Max:” fields within the Image panel show that 

the actual data range for this image is 0 � 402, so these image pixel data values 

must be scaled in a linear fashion to fit within the corresponding display range of 0 � 

255. 

 

 
 

Figure 1: The iImage utility displaying a MRI image of a human brain 
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The Image panel also displays a small histogram (density) plot of the pixel data 

values displayed on its side [Fig. 1].  The histogram plot ranges from the minimum 

pixel data value on the bottom to the maximum pixel value on the top.  Since the 

current image is dominated by very dark pixels (i.e. the black area around the 

border), the scaling of this histogram is skewed and difficult to visualize in such a 

small display window.  Fortunately, the iTools system has a built-in operation for 

creating a separate iPlot utility that displays the density distribution for data objects 

using a histogram plot. 

 

5. Make sure the image object is selected. 

6. From the IDL iImage window menu system, select “Operations > Histogram”. 

 

A separate IDL iPlot window appears, and the histogram density plot for the image is 

displayed in a more robust fashion.  Notice that most of the pixels in the image 

(more than 40,000) have a very low (dark) data value. 

 

7. Once finished viewing the image histogram, close the separate IDL iPlot 

window. 

 

The image histogram window within the Image panel has 3 horizontal bars that the 

user can interactively click-and-drag in order to modify the input data range that is 

used to compute the output scaled image [Fig. 1].  The red bar is used to designate 

the minimum threshold value, the green bar corresponds to the maximum threshold 

value, and the black bar in the middle is used to move the current range up and 

down within the image histogram.  In other words, all input image data pixel values 

that are equal to or less than the current location of the red bar are saturated to an 

output display value of 0 (black), all input image data pixel values that are equal to 

or greater than the current location of the green bar are saturated to an output 

display value of 255 (white), and all of the pixel values in between are scaled in a 
linear fashion from 1 � 254. 

 

8. Click on the green maximum image stretch bar and move it down within the 

histogram plot window.  Notice how the “Max:” field within the Image panel 

updates with the selected pixel data value, and the image display is 

automatically updated based on the stretch modification. 

9. Click on the red minimum image stretch bar and move it up within the 

histogram plot window. 

10. Finally, click on the black range location bar and move it up and down to re-

position the current image stretch. 

11. Once finished experimenting with the histogram manipulation tool, reset the 

stretch to its original state by moving the green and red bars to the top and 

bottom of the window, respectively. 

 

The Image panel within the iImage utility also has built-in regions of interest (ROI) 

tools that can be used to specify certain areas within an image for processing and 

analysis. 

 

12. While the image object is selected, click on the freehand ROI definition  

button to enter into ROI definition mode. 

13. Once the mouse cursor is positioned over the image object it will change to 

the ROI definition pencil pointer.  Click-and-drag with the mouse to draw a 
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ROI on top of a feature within the MRI image.  When the mouse button is 

released the ROI definition will complete to a solid polygon, and the new ROI 

will be highlighted with small green boxes. 

 

Once the ROI definition is complete, the object can be resized and moved by clicking 

on or within the green highlight boxes.  Now that a region of interest has been 

defined, the user can obtain useful information about the image pixels contained 

within the region such as statistics : 

 

14. While the ROI object is highlighted, select “Operations > Statistics…” from the 

menu system. 

 

A separate dialog entitled “Display statistics for the selected item” will appear, which 

lists useful statistical information on the image data contained within the region of 

interest [Fig. 2]. 

 
Note: The exact statistical information that is reported will vary from what appears in Fig. 2 since the ROI 
is drawn in an arbitrary fashion. 

 

 
 

Figure 2: Statistical information on the image data within the defined ROI 

 

15. Once finished viewing the statistical information, close the “Display statistics 

for the selected item” dialog. 

16. While the ROI object is selected and highlighted, right-click on it and select 

“Delete” in order to remove it from the current visualization. 
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Color Palettes, Filtering, and Morphology 
 

Currently the MRI image is displayed with a simple grayscale color palette that was 

read-in from the DICOM file on disk.  This palette displays the image in a very simple 

black-and-white fashion.  In addition to the standard grayscale color palette, IDL 

also has a number of pre-built color tables that can be applied to singe channel 

images in order to give them a colored appearance. 

 

1. Select the image, then press the “Edit Palette…” button on the Image panel. 

2. A separate Palette Editor dialog will appear.  Within this window press the 

“Load Predefined…” droplist and select the “BLUE/GREEN/RED/YELLOW” color 

palette. 

3. Press “OK” to dismiss the Palette Editor dialog. 

 
Instead of displaying the image with the input Black � Gray � White color palette, 

the IDL iImage utility is now applying the selected color table and displaying the 
image brightness values through the color range of Black � Blue � Green � Red � 

Yellow.  This allows the user to visualize the features within the image in color and 

can help highlight aspects of the image that were not readily visible in standard 

black-and-white mode. 

 

4. Experiment with moving the green, red, and black stretch manipulation bars 

on the image histogram once again to see the effect the new color palette has 

on the image display. 

5. Once finished experimenting with the histogram manipulation tool, reset the 

stretch to its original state by moving the green and red bars to the top and 

bottom of the window, respectively. 

 

At this point it may be useful to insert a colorbar into the current visualization so the 

user can see how the input image pixel data range maps to the colors that are 

displayed. 

 

6. Make sure the image object is selected, and from the menu system select 

“Insert > Colorbar” [Fig. 3]. 
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Figure 3: The MRI image displayed with a color palette 

 

In addition to the extraction of statistics, there are a number of other standard 

image processing tools found within the Operations menu.  The operations available 

for an image object include the ability to apply a filter, highlight shapes using 

morphological operators, and rotate or flip the image. 

 

7. Make sure the image object is highlighted and select “Operations > Filter > 

Smooth” from the menu system. 

8. Within the Smooth dialog, leave all parameters set to their default values and 

simply press the “OK” button. 

 

This operation will apply a smoothing image filter, which helps to remove unwanted 

noise using a weighted average.  Notice how the image histogram and colorbar 

automatically update based on the image that is returned from this operation. 

 

9. Select “Operations > Filter > Sobel Filter” from the menu system. 

 

The Sobel filter operation uses the Sobel edge enhancement algorithm to detect and 

highlight edges within the image. 

 

10. Finally, select “Operations > Morph > Morph Open” from the menu system. 

11. Within the Morph Open dialog, leave all parameters set to their default values 

and simply press the “OK” button. 
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The opening morphological operator removes noise from an image while maintaining 

the overall sizes of objects in the foreground.  The resulting visualization should look 

similar to Fig. 4. 

 

 
 

Figure 4: The result of applying Smooth, Sobel and Morph Open operations 

 

12. Once finished viewing the MRI image visualization, close the IDL iImage 

window. 

 

 

 

Line Profiles, Contouring, and Advanced Processing 
 

In the following exercise, the image data from the example data file “nebula.jpg” will 

be input into the iImage utility.  This example data file is located in the “data” 

subfolder. 

 

The file is in JPEG format and contains an image of the famous Ring Nebula taken by 

the Hubble Space Telescope.  In contrast to the single channel MRI image used in 

the last exercise, this dataset is a 3 channel (Red, Green, Blue) 24-bit true color 

image.  In this case, the three color channels are displayed together in order to 

visualize the color image.  Use the following steps to load the “Nebula.jpg” image 

into a new iImage utility : 

 

1. IDL> iImage 
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2. Click on the open file  button on the toolbar of the IDL iImage window. 

3. Select the “Nebula.jpg” file and press “Open”. 

 

The color image be automatically displayed within the IDL iImage window. 

 

4. Move the mouse cursor over the image and notice how the “Pixel Value:” field 

in the Image panel is now reporting 3 pixel values: one each for the R (red), 

G (green), and B (blue) image channels that are combined together to make 

the color display. 

 
In this case, the image data values already fall within the display range of 0 � 255, 

so no scaling is needed. 

 

The iImage utility has a built-in line profile tool that will plot image pixel values along 

a user-defined transect.  This tool will automatically launch a secondary iPlot utility 

containing line plots for the pixel values along the selected line for each of the three 

red, green, and blue image channels. 

 

5. While the image object is selected, click on the line profile  button on the 

toolbar. 

 

Once the mouse cursor is positioned over the image object it will change to the line 

profile pointer.  In order to define a line profile, the user must left-click at the 

desired starting location for the transect, hold down the mouse button, drag to the 

desired ending location for the transect, and release the mouse button in order to 

complete the profile.  Once this is accomplished a separate iPlot utility will be 

launched containing the 3 line profiles (one for each color channel). 

 

6. Using the mouse, click-and-drag from the upper-right hand corner of the 

image to the lower-left hand corner. 

 

The resulting IDL Line Profile window should look similar to Fig. 5. 
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Figure 5: Line profiles extracted from the color JPEG image 

 

7. Once finished viewing the line profiles, close the IDL Line Profile window. 

8. To remove the line from the current visualization, click on it and press the 

Delete key on the keyboard. 

 

Since image data is actually a gridded 2-Dimensional array of pixel values, it can 

also be visualized using some of the other graphical objects available in the iTools 

system.  For example, it is quite easy to insert a contour plot into the existing utility 

in order to make a composite visualization. 

 

9. Make sure the image object is selected. 

10. From the menu system, select “Operations > Contour”. 

11. Within the Contour dialog box, change the “Number of levels” parameter to 

“10”. 

12. Press the “OK” button to dismiss the Contour dialog box. 

13. Select “Window > Visualization Browser…” to view the property sheet for the 

new contour object. 

14. Within the Visualization Browser window, make sure the contour object is 

selected, click on the box to the right of the “Contour level properties” item, 

and select “Edit…”. 
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15. Within the first “All Levels” column, change the “Color” property to bright 

green and hit “OK”. 

16. Close the Visualization Browser window. 

 

The resulting visualization should look similar to Fig. 6. 

 

 
 

Figure 6: Contour map overlaid on top of the image display 

 

In addition to the analysis capabilities exposed within the iTools system under the 

Operations menu, the IDL library includes hundreds of routines that provide 

advanced processing capabilities.  Some of these processing algorithms are very 

specialized, and it is not appropriate to place an item within the Operations menu in 

the iTools system to run all of these more advanced tools.  Fortunately, the iTools 

system was designed in a manner that allows the user to easily pass data back-and-

forth between an iTool utility and the IDL> command prompt. 

 

In the following exercise, the green channel for the current image will be exported 

from the iImage utility to the IDL> command prompt level within the IDL 

Development Environment for specialized processing.  First, the green channel image 

will be smoothed using the SMOOTH function in an effort to minimize noise.  Then, 

the WATERSHED function from the IDL library will be used to segment the image into 

watershed regions and their boundaries.  The watershed algorithm considers the 

grayscale image as a surface, where each local minimum can be thought of as the 

point to which water falling on the surrounding region drains.  The boundaries of the 

watersheds lie on the tops of the ridges.  This operator labels each watershed region 
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with a unique index pixel value, and sets the boundaries to zero so they are readily 

visible. 

 

17. From the IDL iImage window menu system, select “File > Export…”. 

18. In Step 1 of 3 for the IDL Data Export Wizard, select “To an IDL Variable” and 

hit “Next >>”. 

19. In Step 2 of 3, expand the object hierarchy tree until the green image plane 

“Channel 1” can be selected [Fig. 7]. 

 

 
 

Figure 7: Selecting the green channel image for export to IDL 

 

20. Press “Next >>”, and within Step 3 of 3 leave the “IDL Variable Name:” field 

set to the default “Channel_1” and hit “Finish”. 

21. Bring-up the IDL Development Environment window so the IDL> command 

prompt can be accessed.  Execute the following statements at the IDL> 

command prompt. 

22. IDL> HELP, Channel_1 

 

This will report to the output log that a 2-Dimensional byte array with the same 

spatial size as the Ring Nebula image loaded into the iImage utility now exists within 

IDL’s main memory space : 

 
CHANNEL_1       BYTE      = Array[500, 500] 

 

This is a duplicate copy of the same data that is stored in the iImage utility, so it can 

be acted upon in a manner independent of the image that is currently being 

displayed.  Now execute the advanced watershed analysis : 
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23. IDL> smoothed = SMOOTH (Channel_1, 9, /EDGE_TRUNCATE) 

24. IDL> segmented = WATERSHED (smoothed, CONNECTIVITY=8) 

 

Once this is accomplished, a new variable named “segmented” exists at the main IDL 

level which contains the resulting watershed image.  This new image can be loaded 

into the existing iImage utility and compared to the original image using the 

following steps : 

 

25. From the IDL iImage menu system, select “Window > Layout…”.  This will 

bring-up a separate dialog entitled “Window Layout” [Fig. 8]. 

26. Within the Window Layout dialog, change the “Columns:” field to “2” and hit 

Enter on the keyboard.  The Preview pane will update to show the new 

viewplane which will be inserted into the existing iImage utility [Fig. 8]. 

 

 
 

Figure 8: The Window Layout tool within the iTools system 

 

27. Press “OK” to dismiss the Window Layout dialog. 

28. The user will be returned to the iImage utility, where the original viewplane 

will be selected and highlighted with a red border.  Click within the new 

viewplane on the right-hand side in order to designate it as the target for 

future visualization insertion.  Once this is accomplished, the viewplane on 

the right-hand side of the utility will be outlined in red. 

29. Select “Insert > Visualization…” from the menu system. 

30. Within the Insert Visualization dialog, press the “Import Variable…” button. 

31. Within the IDL Variable Browser window, select the “SEGMENTED” variable 

and hit “OK”. 

32. Back within the Insert Visualization dialog, click on the new “SEGMENTED” 

data object and use it to define “IMAGEPIXELS” parameter of a new Image 

object visualization. 
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33. Press “OK” to dismiss the Insert Visualization dialog and insert the image for 

the watershed analysis into the second viewplane. 

 

The watershed analysis has segmented the image into discrete regions, which are 

currently being displayed with the default grayscale color palette.  It is more 

effective to visualize this watershed image using one of IDL’s built-in color tables. 

 

34. Select the new watershed segmentation image and press the “Edit Palette…” 

button. 

35. Within the Palette Editor dialog click on the “Load Predefined…” droplist and 

select the “Rainbow + white” color table. 

36. Press “OK” to dismiss the Palette Editor dialog. 

 

The resulting visualization should look similar to Fig. 9. 

 

 
 

Figure 9: Display of the watershed analysis segmentation image 

 

37. Once finished viewing the two images, close the IDL iImage utility. 
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