&IDL  Workbench Quick Reference

The IDL Workbench is IDL’s graphical user interface and integrated development
environment. The IDL Workbench is based on the Eclipse framework; if you are already
familiar with Eclipse, the appearance and behavior of the IDL Workbench will feel familiar.
This quick reference card will help you get started using the workbench; for more detailed
information on any of the topics covered here, see the IDL help system.

Starting the IDL Workbench

f"llj From the Start menu, sclect IDL 7.0 = @ IDL

(& Click the &g IDLWorkbench icon
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& At the shell prompt, enter idlde
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Select a workspace
A workspace is a directory that CONtains | il werbsnch stores vou projscts n s older called & workspacs,

. . . Chanse 2 workspace Foldsr tn use for this session.
one or more IDL projects; projects in

turn contain IDI. . pro files and other | werkspate: | c:ipocumsnts and settings\daveiotworkspace || [ erouse...

project resources. When you first run
IDL’ 1t creates a new Workspace [[JUse this as the default and do not ask again
directory automatically. By default, it
will be named “IDLWorkspace” and

be located in your "home" directory

(usually in the “Documents and Settings”
directory on Windows machines, and in the directory referred to by the fHOME
environment variable on Macintosh, Solaris, and Linux machines).

You can define multiple workspace directories, but only one can be active during a given
IDL Workbench session. By default, IDL. prompts you to select a workspace each time the
IDL Workbench starts. To avoid the prompting, check “Use this as the default” on

the Workspace Launcher dialog,

To change workspace directories once the IDL Workbench is running, select

File = Switch Workspace. IDL will exit and restart in order to load the new
workspace directory.



IDL Projects

The IDL Workbench uses projects to organize (P Froject Explorer. 52,

and manage your IDL source code files. Each |

project is a directory that is either a sub- Y —
directory of the current workspace directory 1 Default

| = =5 Myapplication
. . . | @ dataimporter.pra
your source code files in a project is not | ) supportfunctions.pro

required, files that are located in project | 4#) dataanalyzer.pro

or that is /inked to the workspace. While storing

directories can take advantage of workbench
features such as multi-file search, task markers
and bookmarks, and the Outline and Problems views.

49 New IDL Project =% Creating a New PI‘OjeCt

New IDL Project

Create anew IDL project.,

To create a new project in your
current workspace, select

Neme: | NeiProject] File = New IDL Project or click

Location T.
e the [z icon. Note that when you first run

() Create the new project fram an existing directary IDL’ a project named “Default” is created
o automatically. You can rename this project
[ZlUpdate 0L path preference when project Is opened or closed by selecting it in the Project Explorer view

and selecting File = Rename.

Creating a Linked Project

In a linked project, project metadata resides in the workspace, but the actual directory
containing the project files is located elsewhere on your file system. To create a linked
project, select “Create the new project from an existing directory” in the New IDL
Project dialog and select the existing directory where your source code files are located.

Adding Files to a Project

You can add files to a project directory in several ways:

* Sclect File > New = IDL Source File or click the “_‘3 toolbar icon.

* Select File = Import... to launch the Import wizard. Select File System from the
General folder and choose the files to import.

* To create a linked file or folder, right-click on the project in the Project Explorer,
select New = File, or New = Folder, and click Advanced. Select
Link to file/folder in the file system and select a file or folder. Metadata
about the selected file or folder will be added to the project, but the file
or folder will not be copied into the project directory.



IDL Editor Features

The IDL Workbench editor incorporates numerous features that make it easy to write
IDL code. The following are some of the highlights.

Content Assist cbij = OBJT HEW('idlitc|

. ® 1DLitcommand
IDL can ltlelp you complete rout.me names. O T
Begin typing the name of a routine or class, ® 1DLitcommandset
then press Ctrl-space to display a list of matching © IpLitcomponent

items. Select the item you want and press Return.

XMAHAGER, Hover HEIP
Syntax: IDL can remind you of the
¥MANAGER. Name. 1D, CATCH = null, CLEANUP = null, EYENT_HANDLER = null 3 )
GROUP LEADER = null. JUST REG = null. NO' BLOCK = nul syntax of commands. Simply
Fress 'F2 For Foau hover the mouse cursor over

a routine name.
Commenting Code

You can comment and uncomment blocks of code in a single operation. Simply select
the lines to be commented (or uncommented) and press
Ctrl-; or click the Toggle Comment button on the toolbar. %

.
Open Declaration

You can open the declaration (the file in which the routine is
resulc = E_EDE (x) defined) for a routine written in IDL by pressing the Control
key and clicking on the routine name when the name is
underlined. The .pro file that defines the routine is opened in a new editor window.
(Routines that are internal to IDL or which are defined in a . sav file are not opened.)
You can also press Ctrl-F3 to open the declaration for the selected routine.

Task Markers and Bookmarks

You can annotate your .pro files with task markers and bookmarks. Task markers allow
you to leave yourself reminders about tasks to be completed later. Bookmarks provide an
casy way to navigate to specific locations in a file. To create
cither, position the mouse pointer in the gutter at the left
edge of the editor window and right-click to display the
context menu, then select Task... or Bookmark... to create s

!‘3 mywidget.pro 55 9 coolapp.pro E
result = F_PDF (x]

Folding 3
i . . . Task...
the mark. You can also create a task by beginning a line in Backmark, .,

the editor with the characters ; TODO. To view tasks or

bookmarks, display the Tasks view or the Bookmarks view.

The context menu also allows you to work with breakpoints v 2:23 ﬁ;:';i:;ers chrkShift-Q
and folding regions, and to display line numbers and

annotations about lines that have changed.

Preferences. ..



IDL Debugging Features

The IDL Workbench provides several ways to inspect your code as it runs.

The Debug Perspective

Although you can use the workbench debugging features
in any perspective, the most common debugging tools and views are collected in the
Debug perspective. To switch to the Debug perspective, click the Debug icon on the
Perspective toolbar in the upper right corner of the workbench. If IDL halts execution
= of your code due to a problem or a

B o |3§$E‘)ebug |

&% Confirm Perspective Switch L breakpoint, the workbench asks if
This kind of launch is configured to open the Debug perspective you want to switch to the Debug
w8/ when it suspends, perspective. Whether you choose
Do o wank bo open this perspective now? to switch or not, select Remember

my decision on the Confirm
Perspective Switch dialog to

[CIremember my decision

avoid being prompted each time.

Using Breakpoints

A breakpoint is a marker in your code that tells IDL to suspend execution when it
reaches the marked line. To set or remove a

. e 3| assistpro 23 ¥ coolapp. | mywidget.
breakpoint, double-click in the grey gutter at SR B cooepooro | &) myvidoe
7

. . args = [assistant, '-server'
the left edgeof the editor window. (You can dir + 'idl.adp']
also select Run = Toggle Breakpoint, press || ¢ if (value losal me '') then .

if (file test(values_file))
i value_ local = '
and remove breakpoints.) Fndif

The Debug View

When IDL encounters a problem or breakpoint that causes it to halt execution of your
code, the Debug view is displayed (whether or
not you switch to the Debug perspective).
Buttons on the Debug view toolbar allow you
to step through your code in various ways or
ed) resume execution. The step commands are also

Ctrl-Shift-B, or use the context menu to set

[ Project E | B2 outline | % Debug 52 =g
Ok 2 gd T

= [T 10L [I0L Application]
= J_f:? I0L Process
=g Ink

SSIST, line: 1
= $MaINg

available on the Run menu, and keyboard
shortcuts are visible there as well.

Inspecting Variable Values

The Variables view shows you the current values of variables in the scope of the routine
selected in the Debug view (usually the routine in which IDL has halted execution. You
can also inspect variables’ values by hovering value_lfcal = n_elements [value] ? s

the mouse pointer over the variable name. value_local = RELNOTES] + Strupcase (value_
Press 2 for focusf + VELUE



Working with Views

The IDL Workbench consists of several siews, each of which contains a different type

of information. The Project Explorer, the =
El Consale 52 2| Tasksw )= Variab\es}

| . L. IDL> print, !wversion
examples of views. You can rearrange views within | xs¢ vin3z Windows Microsoft Window

a perspective; the workbench will remember your Aep 17 2007 32 543

Variables view, and the Console view are all

most recent layout choices. You can also: C -
@ IDL - assist.pro

* Maximize a view by double-clicking on its tab. —_—
File Edit Source Mavigz

Double-click again to restore the view.

. . . . . : o) T
* Drag a view entirely out of the workbench application window. cBa
e Create a Fust 1iew by right-clicking on the view’s tab and | B2 outine £
. . . . e [akid
selecting Fast View. A Fast View is normally minimized and U | 2 8 assistpro

@ assisk

appears as an icon on one edge of the workbench window; Fi
clicking on the Fast View icon temporarily displays the view.

Project Explorer

* Return all the views to their default positions and sizes by

selecting Window —> Reset Perspective.

Perspectives

The IDL Workbench groups views into perspectives for different purposes. By default,
the IDL. Workbench has an IDL perspective and a Debug perspective. You can create
your own perspective by adding and removing views, arranging the views as you prefer,

and selecting Window —> Save Perspective As...

Getting Help

In addition to the Content Assist and Hover Help features, the IDL Workbench
provides several ways to get assistance.

* Selecting Help => Help Contents launches the IDL help viewer, which allows you
to browse the entire IDL. documentation set in hyperlinked electronic format.

* Highlighting a term in the command line or IDL editor and pressing F1 (Windows),
Shift-F1 (Linux & Solaris), or Help (Macintosh) displays the reference topic for the
selected term, if one exists. Typing “?” followed by a search term at the IDL. command
line does the same thing. Help content will appear in the Help view (within the
Workbench interface) by default; you can specify that it should appear in the help
browser instead by opening the Help preference page and specifying that window
context help should open in an infopop.

* Pressing F1/Shift-F1/Help displays help for the currently-selected IDL Workbench
interface element.

* Selecting Help => Cheat Sheets allows you to choose a short, interactive tutorial.

* Selecting Help > Welcome displays the Welcome screen, which provides links to
online resources and longer tutorials.

* Selecting Help => Key Assist or pressing Ctrl-Shift-L displays a list of key bindings
for many of the most common IDL Workbench actions.



Command Line View 5 carmandune =

IDL> result = FFT {varl)| ‘

The IDL Command Line view allows you

to perform ad hoc analyses, compile and launch applications, and create $MAIN$
(main-level) programs interactively.

| B2 command Histary 53

Command History View

The Command History view records each

Command |
& vesterday | command you enter at the IDL. command
= Today Ll line. Double-click on a single command to
RESTORE, FILEPATH(plot_data, 9/18/07 10:10 : .
= re-execute it, or select multiple commands
PLOT, plot_data.time, plot_data 9/18/07 10:10 Jrv'l 4 p K .
< mick b bt R A = and drag them to the Command Line view
I L il —

to re-execute the selected commands. You
can also drag commands to an editor window.

Preferences

Select Window > Preferences to display the IDL Workbench preference dialog. IDL
and the IDL Workbench have numerous preferences, many of which are inherited from
the underlying Eclipse workbench. To locate

S : [Fhae 8= <]
a preference, begin typing text in the filter [ ot v ™ = |
text box at the top left of the dialog; i Dot (T
P . - Dwactanm
preference pages containing items that o irm P (L o e
match the text you enter are displayed. Click L’-:Z»T.'m By }:%
the ? icon at the lower left corner to display kil i G et [ ]
help on the preferences on a given e St oty e ks
# Tean Mistory soe fines): | 220
preference page. ek o ot s s
Note that IDL system preferences and
other preferences that are unique to IDL
are grouped under the IDL heading. ! (oo iats] o o)
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